Finally support Gutenberg - Classic Editor is so outdated

Researching

ST

Sanja Tosanovic

about 2 years ago

I think it is really time for MainWP, to support Gutenberg. It might have had its problems when it first came out, but it is the new standard for more than a year now and works perfectly fine now. It even has a classic editor block included for all those who still want to work with that.

I tend to remove the classic editor plugin wherever I can (already at 80% of my clients). The truth is: Gutenberg is a great approach in its current state and a valid alternative to plugin based layout editors.

And totally independent of what you guys personally think of it, it is there and won’t go away. So I really think it is time to respect this move from the guys at automattic and show that MWP is up to date. Just have a look at the folks at Toolset.com 2 for instance. They were not convinced in the beginning but are successfully and totally moving everything to Gutenberg now. And it works. And it is a sign of professionalism.

Just my two cents. Thanks for reading.

Also I don’t think that this actually is a feature wish but something that inevitably will come and therefore needs far more attention and an official statement. The chance of an upgrade like it was done with MWP 4.0 did not include Gutenberg was a huge drawback.

Activity

ST

Sanja Tosanovic changed the status to Planned

about 2 years ago

DD

Dennis Dornon changed the status to Researching

about 2 years ago

A#

Anonymous #8512

almost 2 years ago

What is not supported with gutenberg ?

SB

Stuart Ball-SCC

13 days ago

Has there been any progress on this? for things like BoilerPlate and Article uploader?


Powered by Convas